List of Router/Switch/Workstation Commands |
||
Sl. No. |
Command |
Comments, if any. |
1 |
access-list <list-num> {permit | deny} <source-ip-address> |
Only standard access list of the format given is supported. |
2 | access-list <100-199> {permit/deny} protocol source-addr [source-mask] [operator operand] destination-addr [destination-mask] [operator operand] | Global command for extended access-lists |
3 | access-list <list-num> {permit/deny} protocol <source-addr> any operator operand | |
4 | access-list <list-num> {permit/deny} protocol <source-addr> any | |
5 | access-list <list-num> {permit/deny} protocol host <source-addr> <dest-addr><dest-mask> | |
6 | access-list <list-num> {permit/deny} protocol any any | |
7 | access-list <list-num>{permit/deny} protocol any host <dest-addr> operator operand | |
8 | access-list <list-num> {permit/deny} protocol host <source-addr> any operator operand | |
9 | access-list <list-num> {permit/deny} protocol <source-addr> <source-wmask> host <dest-addr> | |
10 | banner motd <banner> | |
11 | bandwidth <kilobits> | Required bandwidth, in kilobits per second. |
12 | cdp advertise-v2 | |
13 | cdp enable | |
14 | cdp run | |
15 | cdp holdtime <seconds> | |
16 | cdp timer <seconds> | |
17 | clear arp-cache | |
18 |
clock rate <bps> |
Desired clock rate in bits per second: 1200, 2400, 4800, 9600, 19200, 38400, 56000, 64000 etc. |
19 |
config-register <value> |
Hexadecimal or decimal value that represents the 16-bit configuration register value. It is used at the router start-up. The value range is from 0x0 to 0xFFFF (0 to 65535 in decimal). Normally, the default value is 0x2102 |
20 | configure terminal | |
21 | copy running-config startup-config | |
22 | copy startup-config running-config | |
23 | description <string> | Character string from 1 to 80 characters. |
24 | disconnect | Terminates the suspended telnet session and then logout it. |
25 | copy running-config tftp: | Running configuration file is copied to TFTP server |
26 | copy tftp: running-config | Copies configuration file from TFTP server to new router |
27 | copy tftp: startup-config | Copies configuration file from TFTP server to new router |
28 | debug ip packet | |
29 | disable | |
30 | disconnect | |
31 | disconnect <TELNET_ID> | |
32 | domain-name <domain_name> | Assigns the domain-name to the client. |
33 | dns-server <IP_address> [IP_address_2......IP_address_8] | Allows assigning upto 8 DNS server addresses to the client. |
34 | default-router <IP_address> [IP_address_2......IP_address_8] | Allows assigning upto 8 default-gateway addresses to the client for this range of addresses. |
35 | enable | |
36 | enable password <password> | |
37 | enable secret <password> | |
38 | erase startup-config | |
39 | encapsulation dot1q <vlan id> | Command for router in interface configuration mode. |
40 | encapsulation <encapsulation-type> | Only PPP/HDLC are supported at this time by the simulator. ex: encapsulation hdlc |
41 | encapsulation framerelay [cisco][ietf] | |
42 | end | |
43 | exec-timeout <minutes> [seconds] | seconds is optional. |
44 | frame-relay lmi-type <lmi_type> | LMI type is specific to the entire interface,not to a VC. |
45 | frame-relay map<protocol-name> <ip-address> <dlci_num> | It configures the manual resolution of PVC's. |
46 | frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast | |
47 | frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast cisco | |
48 | frame-relay map<protocol-name> <ip-address> <dlci_num> broadcast ietf | |
49 | frame-relay map<protocol-name> <ip-address> <dlci_num> cisco | |
50 | frame-relay map<protocol-name> <ip-address> <dlci_num> ietf | |
51 | hostname <host-name> | |
52 | interface ethernet 0 | |
53 | interface fa <Port-number> | |
54 | interface fa <Slot-number>/<Port-number> | |
55 | interface fa <Port-number>.<Subint-number> | |
56 | interface fa <Slot-number>/<Port-number>.<Subint-number> | |
57 | interface loopback <port-number> | Loop back interface numbers 0 to 9 are supported |
58 | interface serial 0 | |
59 | ip access-group <named ACL> | Interface sub command to enable named access-list |
60 | ip access-group <num> in | |
61 | ip access-group <num> out | |
62 | ip access-list extended <named ACL> | Global command for Named Access-List |
63 | ip address <ip-address> <sub-net mask> | |
64 | ip default-network <ip-address> | |
65 | ip domain-lookup | |
66 | ip name-server<ip-address> | |
67 | ip nat inside source list <ANUM> pool <WORD> | |
68 | ip nat inside source static <ip-address> <ip-address> | |
69 | ip nat inside | |
70 | ip nat outside source static <ip-address> <ip-address> | |
71 | ip nat outside | |
72 | ip nat pool <WORD> <ip-address> <ip-address> netmask <ip-address> | |
73 | ip nat inside source list <num> interface <int> overload | PAT command |
74 | ip route <prefix> <mask> {next-hop-ip-addr | interface-type} | The command supported by the simulator are: ip route <prefix> <mask> <next-hop-ip> and ip route <prefix> <mask> serial |
75 | ip route 0.0.0.0 0.0.0.0 <ip-address> | |
76 | ip route<ip-address> <ip-address> <ip-address> | |
77 | ip route <ip-address> <ip-address> serial 0 | Not supported at this time |
78 | ip host <name> <ip-address> | Complete syntax for this command: ip host name [tcp-port-number] address1 [address2...address8] |
79 | ip routing | |
80 | ipx routing | |
81 | ipv6 unicast-routing | Enables the forwarding of ipv6 unicast datagrams globally on the router. |
82 | ipv6 router rip <word> | Configures IPV6 RIP routing process and enters router configuration mode for the IPV6 RIP routing process. |
83 | ipv6 router eigrp <as-number> | Enters router configuration mode and creates an EIGRP IPV6 routing process. The "AS" stands for Autonomous System number. |
84 | ipv6 address <ipv6-prefix/prefix-length> | Assigns ipv6 address to an interface. |
85 | ipv6 enable | Enables ipv6 processing on the interface. |
86 | ipv6 rip <name> enable | Enables specified IPV6 RIP routing process on an interface. |
87 | ipv6 eigrp <as-number> | Enables EIGRP for IPV6 on a specified interface. The "AS" stands for Autonomous System number. |
88 | ipv6 ospf <process-id> area <area-id> | Enables OSPF for IPV6 on a specified interface. |
89 |
ip dhcp pool <pool_name> | Creates an addressing pool |
90 |
ip address dhcp | Command to use DHCP to acquire its IP address |
91
new |
ip cef | Enables CEF on the cisco router |
92 | keepalive <seconds> | |
93 | line aux | |
94 | line console 0 | |
95 | line vty | |
96 | logging synchronous | |
97 | login | |
98 | logout | |
98 | lease <days [hours][min] | infinite> | Specifies the duration of the lease |
100 | network <ip-address> | Used with routing rip, igrp etc. |
101 | network <ip-address> < ip-address > area <Area-id> | (For ospf routing) |
102 | no cdp enable | |
103 | no ip address | |
104 | no ip routing | |
105 | no cdp run | |
106 | no frame map <protocol name> <ip-address> <dlci_num> | |
107 | no frame map<protocol-name> <ip-address> <dlci_num> broadcast | |
108 | no frame map<protocol-name> <ip-address> <dlci_num> cisco | |
109 | no frame map<protocol-name> <ip-address> <dlci_num> ietf | |
110 | no ip domain-lookup | |
111 | no ip nat pool <WORD><ip-address> <ip-address> netmask <mask-addr> | Nat pool related command |
112 | no ip nat inside source list <ANUM> pool <WORD> | |
113 | no ip nat inside source static <ip-address> <ip-address> | |
114 | no router eigrp | |
115 |
no router ospf | |
116 | no router rip | |
117 | no shutdown | |
118 | no ip address dhcp | Unconfigures any address that was acquired |
119
new |
mpls label protocol ldp | Configures LDP on all interfaces |
120
new |
mpls ip | Configure MPLS hop-by-hop forwarding for a router interface. |
121 | password <password> | |
122 | ping <host-name> | |
123 | ping <ip-address> | |
124 | ping ipv6 <ipv6-address> | Used to test the connectivity. |
125
new |
ping mpls ipv4 <address> | Used to test MPLS connectivity |
126 | reload | |
127 | resume <TELNET_ID> | |
128 | router eigrp <aut_sys> | |
129 | router ospf <proc_id> | Process_id is locally significant and is used to differentiate different ospf processes running on a router. |
130 | router rip | |
131 | shutdown | |
132 | show access-list | |
133 | show arp | Displays entries in the ARP table |
134 | show cdp neighbor | |
135 | show flash | |
136 | show history | |
137 | show frame-relay lmi | Shows the detailed statistics regarding LMI. |
138 | show frame-relay map | |
139 | show frame-relay pvc <dlci_num> | Shows all the frame relay PVC's terminated and their statistics at a specified router |
140 | show hosts | |
141 | show ip arp | |
142 | show ip eigrp neighbors detail | |
143 | show ip eigrp neighbors | |
144 | show ip eigrp topology | |
145 | show ip eigrp traffic | |
146 | show ip interface brief | |
147 | show ip interface | |
148 | show ip ospf interface | |
149 | show ip nat statistics | |
150 | show ip nat translations | |
151 | show ip ospf database | |
152 | show ip ospf neighbor detail | |
153 | show ip protocols | Displays parameters and current state of the active routing protocol process. |
154 | show ip route | |
155 | show interfaces | |
156 | show interfaces ethernet 0 | |
157 | show interfaces serial 0 | |
158 | show interfaces loopback <Loopback_num> | Loopback interface number,0 to 9 are supported |
159 | show protocols | |
160 | show running-config | |
161 | show sessions | |
162 | show startup-config | |
163 | show users | Displays users connected to the router |
164 | show version | |
165 | show ipv6 rip | Displays information about all current IPV6 RIP processes. |
166 | show ipv6 interface <interface-name> | Displays ipv6 interface configuration information. |
167 | show ipv6 ospf | Displays general information about OSPF routing processes. |
168 | show ipv6 route | Displays routes in the IPV6 routing table. |
169 | show ipv6 protocols | Displays parameters and current state of the active IPV6 routing protocol processes. |
170 | service dhcp | Enables and disables the DHCP server feature on router |
171 | show ip dhcp binding | To view the addresses assigned to clients on dhcp server |
172
new |
show mpls interface | To verify that the interfaces are configured to use LDP. |
173
new |
show mpls forwarding-table | shows MPLS forwarding table information |
174
new |
show mpls ldp neighbor | Shows that the LDP session between routers was successfully established |
175
new |
show ip cef | To display entries in the Cisco Express Forwarding Forwarding Information Base (FIB) or to display a summary of the FIB |
176
new |
show ip cef summary | To display a summary of the IP Cisco Express Forwarding table |
177 | telnet <host-name> | |
178 | telnet <IP-address> | |
179 | traceroute <hostname> | Lists all routers along path to destination and finds the routing problems if any. |
180 | traceroute <ip-address> | |
181 | traceroute ipv6 <ipv6-address> | Traceroute command to determine path of a packet to its destination. |
182
new |
traceroute mpls ipv4 <ipaddress> | used to determine routes to destination |
183 | username <name> password <password> | |
184 | version 2 | For RIPv2 routing |
185 | write erase | |
186 | write memory | |
187 | write terminal | |
188 | no auto-summary | |
189 | no network <ip addr> <ip addr> area <area id> | |
List of Switch Commands Supported |
||
Sl.No. | commands | Comments, if any. |
---|---|---|
1 | banner motd <phrase> | |
2 | copy startup-config running-config | |
3 | configure terminal | |
4 | cdp advertise-v2 | |
5 | copy running-config startup-config | |
6 | cdp holdtime <seconds> | |
7 | cdp timer <seconds> | |
8 | clock set hh:mm:ss <1-31> Month <2004-2035> | |
9 | cdp run | |
10 | duplex <duplex-type> | |
11 | description <phrase> | |
12 | disable | |
13 | enable | |
14 | erase startup-config | |
15 | enable secret <secret> | |
16 | enable password <password> | |
17 | end | |
18 | hostname <name> | |
19 | interface fastethernet <0-0>/<0-24> | Depends on the switch type. For module 0, port 1 the command is interface fastethernet 0/1 |
20 | ip default-gateway <ip-address> | |
21 | ip host<hostname> <ip-address> | |
22 | interface range fastethernet <0-0>/<0-12> | |
23 | interface vlan <vlan #> | You can enter interface config mode. example: interface vlan 1 (config-if)#ip address 192.168.10.1 255.255.255.0 |
24 | ip name-server <ip-address> | |
25 | ip address <ip-address> <subnet mask> | A switch can have one IP address. The IP address of the switch can be accessed only through ports that belong to the management VLAN. |
26 | line vty 0 15 | |
27 | line console 0 | |
28 | login | |
29 | logout | |
30 | mac-address-table static <mac-address> vlan <valn_num> interface fastethernet <pnum> | |
31 | no ip address | |
32 new |
no spanning-tree vlan <vlan-id> | Disables STP on a specified VLAN. |
33 | no shutdown | It re-enables the interface when the interface is disabled.By default interfaces are enabled. |
34 | no switchport mode | |
35 | no switchport <port_security> | |
36 | password <password> | |
37 | reload | |
38 | show interfaces | |
39 | show history | |
40 | show mac-address-table | Displays mac-address-table information |
41 | show version | Display version information for the hardware and firmware |
42 new |
show spanning-tree | Displays spanning-tree statistics, including information about root bridge and port status. |
43 new |
show spanning-tree summary | Displays summary of port states. |
44 new |
show spanning-tree vlan <vlan-id> | Displays STP information for the specified VLAN. |
45 | show vlan | Displays vlan information |
46 | show vlan-membership | Displays vlan membership information |
47 | show vtp status | Displays vtp status information |
48 | show startup-config | |
49 | show flash | |
50 | show running-config | |
51 | show ip interface brief | |
52 | shutdown | Disables a port and shuts-down management vlan. no shutdown command enables a port. |
53 | snmp-server enable traps vtp | |
54 new |
spanning-tree vlan <vlan-id> | Enables STP on a specified VLAN |
55 new |
spanning-tree vlan <vlan-id> root | Configures the root switch. |
56 new |
spanning-tree vlan <vlan-id> priority <priority-num> | Configures switch priority of a VLAN. |
57 new |
spanning-tree vlan <vlan-id> hello-time <hello_time> | Configures STP hello timer. |
58 new |
spanning-tree vlan <vlan-id> forward-time <forward_time> | Configures STP forward-time. |
59 new |
spanning-tree vlan <vlan-id> max-age <max_age> | Configures STP max-age. |
60 new |
spanning-tree port-priority <port_priority> | Configures port priority on a specified interface. |
61 | speed <speed> | Enter switch port speed 10,100, auto. |
62 | switchport access vlan <vlan_num> | |
63 | switchport mode access | Access mode of the switch is set to access |
64 | switchport mode trunk | Access mode of the switch is set to trunk |
65 | switchport port-security mac-address sticky<mac_addr> | |
66 | switchport port-security maximum <max_macadd> | |
67 | switchport port-security violation <violat_mode> | |
68 | switchport trunk encapsulation dot1q | Command for switch in interface configuration mode |
69 | vlan<vlan_num> | VLAN numbers can range 1-1000,However only 64VLANs can be active at a time. |
70 | vlan <vlan_num> name <vlan_name> | VLAN numbers can range 1-1000, VLAN name can be upto 32 characters |
71 | vtp client | Place the switch in VTP client mode. But it does not store VLAN information in non-volatile memory. |
72 | vlan database | |
73 | vtp transparent | SW(vlan)# vtp transparent Sets the switch to VTP TRANSPARENT mode. |
74 | vtp password <password> | Passwords are case sensitive. Passwords should match on all switches in the same domain. |
75 | vtp domain <name> | VTP domain name can be 1 to 32 characters long and identifies the VTP administrative domain for the switch. The domain name is case sensitive. |
76 | vtp pruning | |
77 | vtp server | Place the switch in VTP server mode. Stores VLAN information in non-volatile memory. Generates VLAN advertisements. |
Note: The commands supported by the simulator is given above. The syntax may not be complete for various commands. This is done intentionally to accommodate limited command set supported by the simulator at this point of time. Please refer to official Cisco® website for complete command syntax.