Certexams practice tests and network simulator Register             Login

Home >Network Simulator Labs>OSPF configuration in single area

Available labs  |   Supported Commands  |   Product Help

CertExams.com Simulator Lab Exercises Answers

OSPF configuration in single area

Console Based  |  GUI Based 

Console Based : 

Description: In OSPF single area, you configure OSPF network with an area ID. The configuration example uses four routers working in area 200.

IP Address Assignment Table

R1-s0/0 192.168.1.1 255.255.255.0
R2-s0/0 192.168.1.2

255.255.255.0

R2-s0/1 192.168.2.1 255.255.255.0
R2-s1/0 192.168.3.1 255.255.255.0
R3-s0/0 192.168.2.2 255.255.255.0
R4-s0/0 192.168.3.2 255.255.255.0

Instructions:

1. Based on the given network configuration, use appropriate commands to configure OSPF in networks 192.168.1.0, 192.168.2.0, 192.168.3.0 within area 200

2. Ping R3 and R4 from R1 and verify connectivity

3. Ping R1 and R3 from R4 and verify connectivity

Note : You need to assign the IP addresses and make the interfaces up (by issuing no shutdown commands at appropriate interfaces) for all the devices before proceeding with the following commands

On R1:

R1>enable
R1#configure terminal
R1(config)#interface serial 0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)#exit
R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 200
R1(config-router)#exit
R1(config)#exit
R1#

On R2:

R2>enable
R2#configure terminal
R2(config)#interface serial 0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)#exit
R2(config)#interface serial 0/1
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)#exit
R2(config)#interface serial 1/0
R2(config-if)#ip address 192.168.3.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-router)#network 192.168.1.0 0.0.0.255 area 200
R2(config-router)#network 192.168.2.0 0.0.0.255 area 200
R2(config-router)#network 192.168.3.0 0.0.0.255 area 200
R2(config-router)#exit
R2(config)#exit
R2#

On R3:

R3>enable
R3#configure terminal
R3(config)#interface serial 0/0
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#network 192.168.2.0 0.0.0.255 area 200
R3(config-router)#exit
R3(config)#exit
R3#

On R4:

R4>enable
R4#configure terminal
R2(config)#interface serial 0/0
R2(config-if)#ip address 192.168.3.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)#exit
R4(config)#router ospf 1
R4(config-router)#network 192.168.3.0 0.0.0.255 area 200
R4(config-router)#exit
R4(config)#exit
R4#

On R1:

R1#ping R3
R1#ping R4

On R4:

R4#ping R1
R4#ping R3

GUI Based : 


Instructions:

1. Select R1 from Select Device drop down box.

2. Choose configure > Interface Management > Interface and Connections.

3. In Edit Interface connections tab select the S0 interface and click edit button

4. Configure the IP address as 192.168.1.1 255.255.255.0 and enable the interface status.

5. Choose Router > Dynamic Routing select OSPF from the protocol list and click Edit button.

6. In the Edit IP dynamic routing window enter OSPF process id 1 and click add button to add a network


7. In Add a Network window enter 192.168.1.0 as network address , wildcard mask 0.0.0.255 and area 200 and click OK button.

8. Select device R2 from Select Device drop down box.

9. Repeat steps 2 7 for configuring R2's S0/0 interface ip address as 192.168.1.2 255.255.255.0 , S0/1 interface ip address as 192.168.2.1 255.255.255.0 and S1/0 interface ip address as 192.168.3.1 255.255.255.0 and network addresses 192.168.1.0 ,192.168.2.0 , 192.168.3.0 and wildcard mask as 0.0.0.255 and area 200 10. Select R3 from Select Device drop down box.

11. Repeat steps 2 7 for configuring R3 S0/0 interface ip address as 192.168.2.2 255.255.255.0 and network addresses 192.168.2.0 and wildcard mask as 0.0.0.255 area 200 

12. Select R4 from Select Device drop down box.

13. Repeat steps 2 7 for configuring R4 S0/0 interface ip address as 192.168.3.2 255.255.255.0 and network addresses 192.168.3.0 and wildcard mask as 0.0.0.255 area 200

14. Ping R3 and R4 from R1 and verify connectivity using Utilities > Ping and Traceroute.

15. Ping R1 and R3 from R4 and verify connectivity using Utilities > Ping and Traceroute

Note : You need to assign the IP addresses and make the interfaces up (by issuing no shutdown commands at appropriate interfaces) for all the devices before proceeding with the following commands

Real Time Web Analytics

Clicky